Trung Tâm Đào Tạo Mạng Máy Tính Nhất Nghệ   Trung Tâm Đào Tạo Mạng Máy Tính Nhất Nghệ
Trang Chủ Giới Thiệu Chương Trình Học Tài Liệu Tin Tức F.A.Q Lịch Khai Giảng Học Phí Việc Làm Liên Hệ

Go Back   Trung Tâm Đào Tạo Mạng Máy Tính Nhất Nghệ > CISCO - LINUX - CEH - VIRTUALIZATION - DRAYTEK TECHNOLOGY > [ CISCO ] Thảo luận chung
Đăng Ký Thành Viên Thành Viên Lịch Ðánh Dấu Ðã Ðọc

[ CISCO ] Thảo luận chung Trao đổi các vấn đề chung liên quan đến môn học CCNA
Người Quản Trị :Tôn Ngọc Nghĩa

Vui lòng gõ từ khóa liên quan đến vấn đề bạn quan tâm vào khung dưới , trước khi đặt câu hỏi mới.


Ðề tài đã khoá
 
Ðiều Chỉnh
  #1  
Old 11-10-2009, 18:49
huyflo_it huyflo_it vẫn chưa có mặt trong diễn đàn
Khám Phá
 
Tham gia ngày: Sep 2008
Nơi Cư Ngụ: Ho Chi Minh City
Bài gởi: 323
Thanks: 0
Thanked 20 Times in 19 Posts
BSCI: Cấu hình Routing OSPF Multi Area:Stub,Totally Stub,NSSA

Đây là bài lab trong chương trình BSCI - CCNP ngày xưa mình từng làm, post lên cho anh em tham khảo. Nội dung bài lab hơi xa với chương trình CCNA nhưng theo kinh nghiệm của mình là bổ ích, và nếu bạn nào đam mê công nghệ Cisco vẫn có thể tiếp cận được.
I- Mô hình bài lab:



Mục Tiêu Bài Lab


• Xây dựng mô hình mạng Multi Area OSPF Anonymouse System kết nối với các External Route-IGRP,Default Route-ISP.
• Customize lại các bảng định tuyến và tránh tình trạng bị Flapping từ các vùng ở ngoài và trong OSPF domain khi có sự cố xảy ra.
• Phân biệt được cơ chế hoạt động và chức năng của từng Area.

III. Nội Dung Thực Hiện

• 6 Router Series 3700.
• Router 2,3 là các ABR kết nối đến các Area con.
• Router 4 đóng vai trò là ASBR kết nối đến External Route IGRP.
• Cấu hỉnh Area1 là Stub trên R1 và Totally Stub trên R2.
• Cấu hỉnh Area2 là NSSA trên R3,R4.
• Cấu hình Nat Overload tại interface S0/1 của R2.
• Quảng bá Default Route từ R2 tới ISP vào giao thức OSPF.
• Router R2 sẽ là DR trong OSPF domain,Router R3 không tham gia vào việc bầu chọn DR.
• Thực hiện Summary bảng định tuyến tại các Router ABR và ASBR.


IV. Yêu Cầu

• Ping thành công Router ISP từ R1.
• Ping thành công từ R1 đến R4,R3 đến R5
• Trong bảng định tuyến của R1 chỉ xuất hiện duy nhất tuyến đường Default Route tới ISP.
• Sử dụng câu lệnh show ip ospf neighbor để xác thực R2 là DR.

thay đổi nội dung bởi: huyflo_it, 11-10-2009 lúc 19:34
Những người sau đây đã gửi lời cảm ơn huyflo_it vì bài viết hữu ích này:
Sponsored links
  #2  
Old 11-10-2009, 19:16
huyflo_it huyflo_it vẫn chưa có mặt trong diễn đàn
Khám Phá
 
Tham gia ngày: Sep 2008
Nơi Cư Ngụ: Ho Chi Minh City
Bài gởi: 323
Thanks: 0
Thanked 20 Times in 19 Posts
IV - Các bước thực hiện bài lab

1. Cấu hình cơ bản:


1. Đặt tên Router
2. Đặt IP trên các Interface

2. Cấu hình OSPF cơ bản


o Trên Router R1:
Trích:
router ospf 1
network 172.16.1.4 0.0.0.3 area 1
o Trên Router R2:

Trích:
router ospf 1
network 172.16.1.4 0.0.0.3 area 1
network 172.16.3.16 0.0.0.15 area 0
network 172.16.3.32 0.0.0.7 area 0
o Trên Router R3:

Trích:
router ospf 1
network 172.16.2.4 0.0.0.3 area 2
network 172.16.3.8 0.0.0.7 area 0
network 172.16.3.16 0.0.0.15 area 0
o Trên Router R4:

Trích:
router ospf 1
redistribute eigrp 100 metric 10 subnets
network 172.16.2.4 0.0.0.3 area 2
3. Cấu hình EIGRP trên R4 và R5, thực hiện redistribute giữa OSPF và EIGRP trên R4:

o Cấu hình EIGRP trên R4:

Trích:
router eigrp 100
network 192.168.64.0 0.0.0.3
no auto-summary
o Cấu hình EIGRP trên R5:
Trích:
router eigrp 100
network 192.168.64.0 0.0.0.3
network 192.168.64.0 0.0.0.255
no auto-summary
o Cấu hình Redistribute trên R4:

Trích:
router ospf 1
redistribute eigrp 100 metric 10 subnets
router eigrp 100
redistribute ospf 1 metric 2000 200 255 1 1500
4. Nhận xét sau khi cấu hình xong OSPF cơ bản, EIGRP và redistribute.


o Bảng định tuyến trên R1:



o Bảng định tuyến trên R2:


o Bảng định tuyến trên R3:


o Bảng định tuyến trên R4:


o Bảng định tuyến trên R5:


o Thực hiện lệnh show ip ospf database trên R1:

Trích:
OSPF Router with ID (172.16.1.6) (Process ID 1) Summary Net Link States (Area 1)
Link ID ADV Router Age Seq# Checksum
172.16.2.4 172.16.3.33 1401 0x80000001 0x00D189
172.16.3.8 172.16.3.33 519 0x80000001 0x000E8B
Summary ASB Link States (Area 1)
Link ID ADV Router Age Seq# Checksum
192.168.64.1 172.16.3.33 1218 0x80000001 0x001B54
Type-5 AS External Link States
Link ID ADV Router Age Seq# Checksum Tag
192.168.64.0 192.168.64.1 1416 0x80000001 0x002930 0
192.168.64.48 192.168.64.1 359 0x80000001 0x0047E1 0
192.168.64.52 192.168.64.1 358 0x80000001 0x001F06 0
192.168.64.56 192.168.64.1 358 0x80000001 0x00F62A 0
192.168.64.60 192.168.64.1 358 0x80000001 0x00CE4E 0
• Trên R1,R2,R3 tất cả các route tới các Interface loopback của R5 đều được quảng bá bới gói tin LSA loại 5 (Type-5 External AS Link State).

• Các gói tin quảng bá OSPF ngoài vùng được ABR quảng bá vào vùng bên trong với gói tin LSA kiểu 3 hoặc 4 ( Summary link entry ) – Trong bảng định tuyến có ký hiệu “O-IA”
• Kiểu 3: ABR Router gửi thông tin summary về link state của area này cho area khác thông qua backbone area (area 0)
• Kiểu 4: ABR Router gửi thông tin về ASBR (nếu có) của area này cho area khác thông qua backbone area (area 0) nhưng lưu ý Stubby Area và Totally Stubby Area không nhận kiểu 4 này.
• Các Router R2, R3 đóng vai trò là ABR





Router R4 đóng vai trò là ASBR


5. Cấu hình các vùng thành Stub, NSSA

o Trên R1:

Trích:
router ospf 1
area 1 stub
o Trên R2:

Trích:
router ospf 1
area 1 stub
o Trên R3:
Trích:
router ospf 1
area 2 nssa default-information-originate

o Trên R4:

Trích:
router ospf 1
area 2 nssa
Những người sau đây đã gửi lời cảm ơn huyflo_it vì bài viết hữu ích này:
  #3  
Old 11-10-2009, 19:24
huyflo_it huyflo_it vẫn chưa có mặt trong diễn đàn
Khám Phá
 
Tham gia ngày: Sep 2008
Nơi Cư Ngụ: Ho Chi Minh City
Bài gởi: 323
Thanks: 0
Thanked 20 Times in 19 Posts
Smile

6. Nhận xét sau khi cấu hình các vùng Stub,NSSA
o Bảng định tuyến trên R1:



Tất cả các Route tới các Interface Loopback trên R5 đều được thay thế bởi 1 Route default tới 172.16.1.5 ( Interface của route ABR R2)

o Bảng định tuyến trên R3:


  • Tất cả các Route tới các Interface Loopback trên R5 đều được thể hiện là N2 – OSPF NSSA external type 2.
  • Các gói tin Update LSA Type 7 thông qua ASBR được chuyển thành LSA Type 5 và truyền vào vùng back bone cho các Area khác học



7. Cấu hình Default Route trên Router R2, và truyển thông tin Default Route vào miền OSPF.


Trích:
ip route 0.0.0.0 0.0.0.0 192.168.1.1
router ospf 1
default-information originate
8. Thực hiện Dynamic NAT trên R2, cho các mạng bên trong ra ngoài Internet.


Trích:
access-list 1 permit any
ip nat inside source list 1 interface FastEthernet0/1 overload
interface FastEthernet0/1
ip nat outside
interface Serial0/0
ip nat ínide
interface FastEthernet0/0
ip nat inside
9. Kiểm tra lại bảng định tuyến.

o Tất cả các Router đều có Default route trỏ về phía Interface gần Interface F0/1 của R2 nhất.
o Thực hiện lệnh ping tới tất cả các Interface trong sô đồ thành công
o Thực hiện lệnh Ping ra ngoài mạng Internet thành công.
Những người sau đây đã gửi lời cảm ơn huyflo_it vì bài viết hữu ích này:
Sponsored links
Ðề tài đã khoá

Bookmarks

Ðiều Chỉnh

Quyền Sử Dụng Ở Diễn Ðàn
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is Mở
Smilies đang Mở
[IMG] đang Mở
HTML đang Tắt

Chuyển đến

Similar Threads
Ðề tài Người Gởi Chuyên mục Trả lời Bài mới gởi
[eBooks] Testout 642-601 BSCI trongnghia00 Tài Liệu Học Tập 0 23-07-2009 03:59
Bàn luận về LSA type và area type trong OSPF chút nhé longphi11 [ CISCO ] Thảo luận chung 2 14-10-2008 15:48
[Tutorial] [Viet-document]OSPF area types tranmyphuc1988 [ CISCO ] Thảo luận chung 0 23-09-2008 15:37
[Discuss] BSCI-có ai thi module này không? longphi11 [ CISCO ] Thảo luận chung 1 30-08-2008 22:13
Giúp hiểu rõ về Stub Zone tony Network Infrastructure 5 22-04-2007 10:16



Múi giờ GMT +7. Hiện tại là 11:16
Powered by: vBulletin Version 3.8.7
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Ad Management by RedTyger